Export Configuration
In ETA, an export configuration is used to automatically export time series to CSV, XLS, or XLSX files. The export configuration works like a simple macro for standardized time series export.
An export configuration is saved as an Export template. Virtually any number of export templates can be saved and retrieved.
Each export template can contain several Export files. This means that with an export macro time series can be exported automatically in several files.
With the Time_Series_ImportExport component, the TOP-Energy Export-Template created in ETA can be automatically executed in TOP-Energy without having to start ETA every time. How to proceed is shown in the article about the TOP-Energy Export-Template.
Creating and Editing an Export Configuration
To create or edit an export macro in ETA, select the menu items File → Export → Create export configuration (see following figure).
The following window opens.
Export Templates
The upper part of the window is dedicated to the export templates.
You can select one from the list of Export templates. To load it, click the
Load the selected export template button.
If ETA was started via the TOP-Energy Time_Series_ImportExport component, you select the TOP-Energy Export-Template (see following figure). This links the export configuration with the TOP-Energy component Time_Series_ImportExport.
The prerequisite for loading export templates is that templates have been created beforehand. For this purpose, use the
Create a new export template button. In the window that opens, enter the name of the template. The template is stored in the folder selected under Extras → Options → Directories → ExportTemplateDir, typically: C:\Users\$User name$\AppData\Roaming\TOP-Energy\eta$version$\exp_tpl.
If the button
Save data to the current selected export template is clicked, a blue frame indicates that the function is activated. ![]()
When you later confirm the export and close the window with OK, the settings are saved under the selected template. Otherwise, there will be an extra enquiry.
The button
Delete the selected export template deletes the template from the Windows directory.
Export Files
The lower part of the Export Time Series window defines the export files.
The List of export files contains the files created with the template selected above. If no template is selected or no export file has been added the list is empty.
The
Add a new export file button located to the right of the list field creates new export files in CSV, XLSX, or XLS formats. In the window that opens, enter the desired file path and name.
If an Export file is selected the time series can be dragged and dropped from the List of available time series (on the left in the window), to the right side under Time series to be exported for current selected file in the desired order (as in simple time series export, see following figure).
There the time series can be renamed via the context menu, which is reached by right-clicking on the time series name in the table header.
With the button
Edit parameters of the current selected export file the export file can be saved in a different location or under a different name.
The button
Remove current selected export file takes the export file from the list of available time series, but does not delete it. The export file can be deleted in Windows Explorer by removing it from its storage location.
Exporting by the Export Configuration
Pressing the OK button at the bottom of the window starts the execution of the export template. If this was not previously selected with the button
(Save data to the current selected export template), the system asks whether the current settings should be saved under the template (see following figure).
When running the export, Excel should be closed to avoid possible conflicts.
If the configuration of the file to be exported is to be edited the procedure described above is repeated. Select the appropriate export template from the drop-down menu and then click the
Load the selected export template button. The file will then appear in the List of export files. You can now add more time series from the list of available time series by dragging and dropping. Then save with OK and execute the export.
Video
The video shows how to create and run an export configuration in ETA. Time series can be automatically exported to an export file using such an export configuration.





